Windows 10 + Vagrant + Virtualbox の最新版の組み合わせの問題

アップグレードして Windows 10 に上げたPCで、Vagrant の開発環境を更新した際になんかエラーが出るようになりました。

それぞれのツールを最新版にしたのですが、

  • Vagrant 1.8.1
  • Oracle Virtual Box 5.0.16

次のようなエラーが出てしまいます。


VBoxManage.exe: error: Failed to attach the network LUN (VERR_INTNET_FLT_IF_NOT_FOUND)

一つの解決法は Virtual Box を5.0.10に戻すことらしいのですが、古いバージョンに戻すのも(他の修正で直っている箇所もあるだろうから)あまりいい感じがしません。

こちらに載っているやり方で、[コントロール パネル]-[ネットワークとインターネット]-[ネットワーク接続]から、Virtualbox host only network のプロパティを開き、NDIS6 Bridge をオンに。(オフなら問題なく動いてるはず、ということですが、オフにしてオンでも)

すると、理由は良く分からないけど動くようになる、ということです。自分の環境もこれで直りました。